Home Forums General Discussion Quick help ( PC/Mac, with Shockwave installed )

This topic contains 43 replies, has 15 voices, and was last updated by  Anonymous 13 years ago.

  • Author
    Posts
  • #4782

    Anonymous

    Hi there,

    If you have a PC or Mac installed, could you test this and let me know if it works, or breaks ( especially if you are Mac based )

    Load up the app, then select the GOOGLE image, in the bottom right corner.

    Type in some words to search for ( NOTE: You’ll have to say yes to a security question, to allow the app to download the images from the various websites ).

    http://www.candointeractive.com/art/gallery/test/

    Some search words might be…

    gamedevelopers.ie
    cando interactive
    torc interactive
    starcave
    kapooki

    If you find any cool images, post the search words… I’m sure there are a few Hoff-ally great images out there on the web Pete :)

    Regarding the app, you can press SPACE to zoom into images, if you clicked on them first ( rather than using the arrow key navigation I just hacked in there ).

    Many thanks in advance…
    Mal

  • #27260

    Anonymous
  • #27261

    Anonymous

    > Can I ask what decides which images to use?

    It uses the images that download first, in order.

    > enter on the numpad isn’t recognised though in the search bar

    Will get that fixed for the next build :)

    Thanks for testing…
    Mal

  • #27262

    Anonymous

    Had no problem/worked well in firefox/xp.

  • #27263

    Anonymous

    yeah worked fine for me too, firefox/xp

  • #27273

    Anonymous

    Not working here. Windows xp 64 ed(I’m testing it for work…) and Firefox 1.0.7. The same problem I have with flash movies using the Flash 8 player. Simply they dont appear…. Any other technical information you need?

    -=edit=-
    Reinstalled the shockwave plugin and works fine now. Odd….

    Pretty cool. I searched for akira…

  • #23968

    Anonymous

    LMAO :lol:
    Aaaaah, that auto gallery thingie is *GREAT* man, seriously :)
    I loved that auto generated h0ff gallery, hilarious stuff!

    (XP Pro and standard explorer, standard shockwave plugin. ie not the latest AFAIK)

    “When it’s time to get off, it’s time to get H*ff” :lol:

  • #26517

    Anonymous

    Mal

    No Go on OSX 10.4.3, Safari 2.02, Shockwave 8.

    Loads ok but on gallery launch get the ‘shockwave errors caused playback problems, contact author, unable to continue” dialog.

    Let me know if you need any further testing done.

    Cheers

    Peter

  • #26747

    Anonymous

    Thanks all for testing…

    Just uploaded a slighly newer version, which allows me to replace the crowds, as well as a number of other bug fixes etc.

    http://www.candointeractive.com/art/gallery/spin/

    Peter, did you try to load the gallery in the last 30 minutes? I uploaded a build by accident, that might have broken it.

    Could you check if it is a bit more Mac friendly now ( you might need to clear your cache )?

    Regards…
    Mal

  • #26744

    Anonymous

    I just keep getting an out of memory error while saving member 1 of plyr cast 4 – too lazy to investigate why…is it targeting an unusual location for download or summat?

  • #26705

    Anonymous

    So I am not sure what version is installed by default on Windows XP Pro, but anyway, I get this error message, you know “trying to connect to Macromedia to update”. Sure enough, since all the ports in the college are blocked, it doesn’t install the latest version (apparently you need Shockwave 10 ?)

    And yet …. ah no, wait, no I can’t play it anymore on this machine because it tries to download the update… go figure :roll:

    But anyway, it did work earlier without anything else than the default Shocwave plugin.

    Weird.

    And yes, I haven’t said it in a long while, but I think it’s deserved right now:
    “Windows sucks. And I mean, sucks like my balls are full of oxygen, and it’s drowning.”
    :?

  • #26702

    Anonymous

    i’m on OSX 10.4.2, safari 2.01 .. an still no go

  • #27283

    Anonymous

    get this error

  • #27284

    Anonymous

    Same error as beans

  • #27285

    Anonymous

    Same error as above
    On xp sp1 ie6 and xp sp2 ie6 sp1

  • #27287

    Anonymous

    Thanks for all the feedback and testing!

    I’m adding quite a few new features into the app, it looks like I’ve also added a bug in there :)

    For those who are having problems ( on both PC and Mac ), is the art gallery appearing OK initially, and are the errors only occurring when you do the GOOGLE search?

    Also, if you have had a problem, could you let me know if this link works OK?

    http://www.candointeractive.com/art/gallery/masters

    Many thanks!
    Mal

  • #27288

    Anonymous

    Masters works fine, but I’m getting the same error as the boys above now…

  • #27289

    Anonymous

    Yikes!

    When the broken version loaded, did you see the 3D gallery first, and then did a google search, or did it break straight away before viewing it in 3D?

    Here’s a new test URL, with a bit of additional checking, when loading resources.
    http://www.candointeractive.com/art/gallery/spin/test04.htm

    Mal

  • #27290

    Anonymous

    hi mal.. just testing again for you..

    i get the same error message as i posted above..even with your latest version

    I can see the gallery, but it’s impossible to move from that or use Google

    my shockwave version is 7.0 r24

  • #27291

    Anonymous

    The spintest is the same error. The shockwave loads, but once it reaches 100% you get the error and nothing happens….

  • #27292

    Anonymous

    I just get a “Out of memory while saving member 1 of PLAYER-CAST 4″ message”

  • #27293

    Anonymous

    I’ve just got the error to occur on a PC here, am fixing at the mo.

    Will hopefully have a new ( and working :P ) test version in around an hour.

    Mal

  • #27295

    Anonymous

    OK, the link should be working OK now ( for PC owners at least… hopefullu the fix will work on Mac also ).

    <BORING>
    The new code to load custom crowds, using a tiled PNG file, was failing to detect the alpha channel on import on some computers ( a known Director 8.5 bug ), so I’ve implemented a fix for that.
    </BORING>

    Also, if you are searching for screenshots of retro games, the app will now detect if the resolution of the resulting screenshot is approximate to one of the old console screen resolutions, and won’t filter the pixels ( making it more like the original ).

    Here’s the hopefully working link again…

    http://www.candointeractive.com/art/gallery/spin

    Pete, you can start googling for those h0ff-al pictures again :)

    Mal

  • #27297

    Anonymous

    hmmmm….are you going to hit me if I say its still giving me the “Out of memory while saving member 1 of PLAYER-CAST 4″ message” error. :(

    Tested under both Firefox and IE, made sure it wasnt a cache thing either. Sorry but still not working

  • #27298

    Anonymous

    Getting the same error as earlier again

  • #27299

    Anonymous

    Whatever you changed since the first version you showed us, it’s not working anymore, and I get the same error that lk_ just mentions
    (XP Pro, IE 6, Shockwave default plugin)

  • #27300

    Anonymous

    Darned tootin! I tried it on a few computers here, and they all seem to work, it would be great to get this bug found and fixed!

    Maybe it’s not the new crowd code after all.

    Could you please try these two links…

    Update ( No Crowd, but default people look dimensionally challenged )

    http://www.candointeractive.com/art/gallery/no_crowd

    Update ( With Crowd – you should see Mario, Luigi etc )

    http://www.candointeractive.com/art/gallery/crowd

    If both of these still break, I’ll upload one with some debug messages, to try to figure out where it’s crashing.

    Thanks! ( it looks like I owe quite a few drinks at the Xmas shindig!!! :) )
    Mal

  • #27301

    Anonymous

    first one works fine
    the second one has is still getting the out of memory error

  • #27302

    Anonymous

    Both work fine for me Mal

  • #27303

    Anonymous

    > the second one has is still getting the out of memory error

    Cheers for checking…

    The basic Shockwave installation doesn’t automatically force support for PNG files.

    Could you re-check with this link, which will ask Shockwave to automatically get the support for PNGs in the background? ( could have sworn I had checked this already, but I hadn’t… DOH! )

    http://www.candointeractive.com/art/gallery/crowd2

    I’ve updated the other links above, hopefully they will all work now.

    Mal

  • #27305

    Anonymous

    All working but I’m getting this effect on all of them now….

  • #27306

    Anonymous

    Both seem to work fine now mal + someones slightly addicted to mario :P

  • #27308

    Anonymous

    Thanks all for testing, looks like the bug has been squashed, just like jumping on a turtoise!

    > someones slightly addicted to mario

    Mamma mia, I doon noo wat u aare talkin about! :)

    lk_, the graphical problem might have something to do with some 3D stuff you have been running during the day… if you re-start later on, could you let me know if the problem still occurs? With Shockwave, you don’t have direct access to the 3D card, just a higher level API to use the 3D engine that Intel developed ( that in turn uses either Direct3D ( on PC ), OpenGL ( PC or Mac ), or reverts to Software ( both ) ).

    Mal

  • #27311

    Anonymous

    Gone now. The laptop got a blue screen of death afte visiting the site. See the “Laptop for Audio” thread for what I think of my laptop… All working now tested under both Win XP, and in 64xp all working fine. Real nice work Mal.

  • #27312

    Anonymous

    just tryed on the PSP got giant orange screen:)

  • #27543

    Anonymous

    I have a slightly newer version, if anyone has the time to test ( esp Mac )

    http://www.candointeractive.com/art/gallery/test/

    I’ve had to, once again, re-arrange how the gallery data is collated ( for security, extensions ), which always makes me a bit nervous about compatibility etc.

    Anywho, let me know if you get a chance to try it and it works / breaks.

    BTW if you find any cool searches, you can share them using this shortcut URL to the google search…

    Example #1

    Search for images on candointeractive.com using site:candointeractive.com

    http://www.candointeractive.com/art/gallery/test/index_url.htm?search=site:candointeractive.com

    Example #2

    Search for Torc and Interactive
    torc+interactive

    http://www.candointeractive.com/art/gallery/test/index_url.htm?search=torc+interactive

    I see Pete’s mugshot in the above search :)

    Regards…
    Mal

  • #27545

    Anonymous

    Works fine, only prob is that theres no way to mute the sound, even when I create my own gallery, not that I don’t love the Mario banter though……

  • #27546

    Anonymous

    I’ll search for new voice overs and music for the next beta ;)

    Don’t worry, when you download the art gallery builder, you can choose your own! The google search just uses the existing sound effects ( google search will be removed for the final version, it’s just in as a bit of fun for now )

    Mal

  • #27547

    Anonymous

    Actually shockwave lets ya do it anyways, if you right click you can get into volume controls.

  • #27548

    Anonymous

    works like a charm mal :D

  • #27568

    Anonymous

    Hi Mal,

    When I first ran it on (XP SP2, IE 6) it all worked great. My first search via google thingy resulted in a prompt about security access.

    results (jedi, star wars, etc.) were displayed no problem.

    Two Issues though:

    1. When I closed the window that the movie was playing in, all other instances of IE Browser windows crashed at the same time.

    2. My google search filter settings are set to “Filter My Results” which gets rid of all the “crap” (sex links, etc.).

    However, as a test (REALLY!), I typed in “Paris Hilton” in my IE Google Search, and the crap was filtered out. I did the same search via your app, and no filtering occurred. I don’t know if Director/Shockwave can access the preferences set in the google search cookies, but I would certainly see this as an issue that should be looked at.

    Just F.Y.I.

  • #27641

    Anonymous

    > Two Issues though:

    > 1. When I closed the window that the movie was playing in, all other instances of IE Browser windows crashed at the same time.

    I’ll look into this, I have to optimise the memory usage etc.

    > 2. My google search filter settings are set to “Filter My Results” which gets rid of all the “crap” (sex links, etc.).

    There is now a filter option

    Thx for the feedback!
    Mal

  • #27967

    Anonymous
  • #27981

    Anonymous

    Very nice Mal. Best of luck with it I really hope its widely used and you guys get the revenues needed to do what you want.

The forum ‘General Discussion’ is closed to new topics and replies.